#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[^\\]*(?=\\[A-Z0-9]{40}$)"
Local $sString = "[hello]" & @CRLF & _
"PSPath" & @CRLF & _
"Microsoft.PowerShell.Security\Certificate::CurrentUser" & @CRLF & _
"Microsoft.PowerShell.Security\Certificate::SmartCardRoot" & @CRLF & _
"Microsoft.PowerShell.Security\Certificate::Root" & @CRLF & _
"Microsoft.PowerShell.Security\Certificate::CurrentUser\Root\CDD4EEAE6000AC7F40C3802C171E30148030C072" & @CRLF & _
"Microsoft.PowerShell.Security\Certificate::CurrentUser\Root\BE36A4562FB2EE05DBB3D32323ADF445084ED656" & @CRLF & _
"Microsoft.PowerShell.Security\Certificate::CurrentUser\Root\A43489159A520F0D93D032CCAF37E7FE20A8B419" & @CRLF & _
"Microsoft.PowerShell.Security\Certificate::CurrentUser\Root\92B46C76E13054E104F230517E6E504D43AB10B5" & @CRLF & _
"Microsoft.PowerShell.Security\Certificate::CurrentUser\Root\8F43288AD272F3103B6FB1428485EA3014C0BCFE" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")