re = /[^\\]*(?=\\[A-Z0-9]{40}$)/m
str = '[hello]
PSPath
Microsoft.PowerShell.Security\\Certificate::CurrentUser
Microsoft.PowerShell.Security\\Certificate::SmartCardRoot
Microsoft.PowerShell.Security\\Certificate::Root
Microsoft.PowerShell.Security\\Certificate::CurrentUser\\Root\\CDD4EEAE6000AC7F40C3802C171E30148030C072
Microsoft.PowerShell.Security\\Certificate::CurrentUser\\Root\\BE36A4562FB2EE05DBB3D32323ADF445084ED656
Microsoft.PowerShell.Security\\Certificate::CurrentUser\\Root\\A43489159A520F0D93D032CCAF37E7FE20A8B419
Microsoft.PowerShell.Security\\Certificate::CurrentUser\\Root\\92B46C76E13054E104F230517E6E504D43AB10B5
Microsoft.PowerShell.Security\\Certificate::CurrentUser\\Root\\8F43288AD272F3103B6FB1428485EA3014C0BCFE
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end