const regex = /[^\\]*(?=\\[A-Z0-9]{40}$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\\\]*(?=\\\\[A-Z0-9]{40}$)', 'gm')
const str = `[hello]
PSPath
Microsoft.PowerShell.Security\\Certificate::CurrentUser
Microsoft.PowerShell.Security\\Certificate::SmartCardRoot
Microsoft.PowerShell.Security\\Certificate::Root
Microsoft.PowerShell.Security\\Certificate::CurrentUser\\Root\\CDD4EEAE6000AC7F40C3802C171E30148030C072
Microsoft.PowerShell.Security\\Certificate::CurrentUser\\Root\\BE36A4562FB2EE05DBB3D32323ADF445084ED656
Microsoft.PowerShell.Security\\Certificate::CurrentUser\\Root\\A43489159A520F0D93D032CCAF37E7FE20A8B419
Microsoft.PowerShell.Security\\Certificate::CurrentUser\\Root\\92B46C76E13054E104F230517E6E504D43AB10B5
Microsoft.PowerShell.Security\\Certificate::CurrentUser\\Root\\8F43288AD272F3103B6FB1428485EA3014C0BCFE
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}