import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^\\\\]*(?=\\\\[A-Z0-9]{40}$)";
final String string = "[hello]\n"
+ "PSPath\n"
+ "Microsoft.PowerShell.Security\\Certificate::CurrentUser\n"
+ "Microsoft.PowerShell.Security\\Certificate::SmartCardRoot\n"
+ "Microsoft.PowerShell.Security\\Certificate::Root\n"
+ "Microsoft.PowerShell.Security\\Certificate::CurrentUser\\Root\\CDD4EEAE6000AC7F40C3802C171E30148030C072\n"
+ "Microsoft.PowerShell.Security\\Certificate::CurrentUser\\Root\\BE36A4562FB2EE05DBB3D32323ADF445084ED656\n"
+ "Microsoft.PowerShell.Security\\Certificate::CurrentUser\\Root\\A43489159A520F0D93D032CCAF37E7FE20A8B419\n"
+ "Microsoft.PowerShell.Security\\Certificate::CurrentUser\\Root\\92B46C76E13054E104F230517E6E504D43AB10B5\n"
+ "Microsoft.PowerShell.Security\\Certificate::CurrentUser\\Root\\8F43288AD272F3103B6FB1428485EA3014C0BCFE\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}