import Foundation
let pattern = #"%([a-zA-Z-_])*\s?\{[\s,]*\n(.*?)\n\}\s*\n"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
%abstract-class {
  font-family: Verdana;
}
%abstract-class {
  font-family: Verdana;
}
%abstract-class{
  font-family: Verdana;
  font-site: 100%;
}   
bla {
lkdjkjd: 10px;
}
%abstract-class {
  .abstract-class {
    font-family: Verdana;
  }
  a,
  a:hover {
  }
}   
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
    var groups: [String] = []
    for rangeIndex in 1 ..< match.numberOfRanges {
        let nsRange = match.range(at: rangeIndex)
        guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
        let string = (testString as NSString).substring(with: nsRange)
        groups.append(string)
    }
    if !groups.isEmpty {
        result.append(groups)
    }
}
print(result)