using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\-)(.*?)(?=\.aqa)";
string input = @"http://poa-claroco.aqa.int.zone:8080/servlet/Turbine/frm/single/";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}