$re = '/(?<=\-)(.*?)(?=\.aqa)/';
$str = 'http://poa-claroco.aqa.int.zone:8080/servlet/Turbine/frm/single/';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);