const regex = /(?<=\-)(.*?)(?=\.aqa)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\-)(.*?)(?=\\.aqa)', '')
const str = `http://poa-claroco.aqa.int.zone:8080/servlet/Turbine/frm/single/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}