re = /(?<=\-)(.*?)(?=\.aqa)/
str = 'http://poa-claroco.aqa.int.zone:8080/servlet/Turbine/frm/single/'
# Print the match result
str.match(re) do |match|
puts match.to_s
end