#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d{3}-\d{3}-\d{4}$"
Local $sString = "333-333-4444" & @CRLF & _
"14157059247" & @CRLF & _
"123-456-7890" & @CRLF & _
"1234567890" & @CRLF & _
"123456789" & @CRLF & _
"123-4567-890"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")