const regex = /^\d{3}-\d{3}-\d{4}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{3}-\\d{3}-\\d{4}$', 'gm')
const str = `333-333-4444
14157059247
123-456-7890
1234567890
123456789
123-4567-890`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}