re = /^\d{3}-\d{3}-\d{4}$/m
str = '333-333-4444
14157059247
123-456-7890
1234567890
123456789
123-4567-890'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end