package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{3}-\d{3}-\d{4}$`)
var str = `333-333-4444
14157059247
123-456-7890
1234567890
123456789
123-4567-890`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}