package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\s*\d{8}\s*(?:,|$))+$`)
var str = `12345678,23435678,23434422,23432423
12345678,12345`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}