re = /^(?:\s*\d{8}\s*(?:,|$))+$/m
str = '12345678,23435678,23434422,23432423
12345678,12345'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end