const regex = /^(?:\s*\d{8}\s*(?:,|$))+$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\s*\\d{8}\\s*(?:,|$))+$', 'mg')
const str = `12345678,23435678,23434422,23432423
12345678,12345`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}