$re = '/^(?:\s*\d{8}\s*(?:,|$))+$/m';
$str = '12345678,23435678,23434422,23432423
12345678,12345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);