using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Za-z]+(?: [A-Za-z]+)* *[ -:] *[A-Za-z]+(?: [A-Za-z]+)*$";
string input = @"Villa-Levski
Villa:Levski
Villa Levski
Villa123-Levski123
Villa123:Levski123
Villa123 Levski123
Villa - Levski
Villa : Levski
Villa Levski
Manchester United - Tottenham HotSpurt";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}