// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[A-Za-z]+(?: [A-Za-z]+)* *[ -:] *[A-Za-z]+(?: [A-Za-z]+)*$").unwrap();
let string = "Villa-Levski
Villa:Levski
Villa Levski
Villa123-Levski123
Villa123:Levski123
Villa123 Levski123
Villa - Levski
Villa : Levski
Villa Levski
Manchester United - Tottenham HotSpurt";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}