import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Za-z]+(?: [A-Za-z]+)* *[ -:] *[A-Za-z]+(?: [A-Za-z]+)*$";
final String string = "Villa-Levski\n"
+ "Villa:Levski\n"
+ "Villa Levski\n"
+ "Villa123-Levski123\n"
+ "Villa123:Levski123\n"
+ "Villa123 Levski123\n"
+ "Villa - Levski\n"
+ "Villa : Levski\n"
+ "Villa Levski\n"
+ "Manchester United - Tottenham HotSpurt";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}