using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\bfunction((?!function).)*\((.*?)\)\s*{)";
string input = @"/** * recursive function to do whatever */ function demo (el, hop) { /*whatever*/ }
function to do whatever */ function demo (el, hop) {";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}