import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\bfunction((?!function).)*\\((.*?)\\)\\s*\\{)";
final String string = "/** * recursive function to do whatever */ function demo (el, hop) { /*whatever*/ }\n"
+ "function to do whatever */ function demo (el, hop) {";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}