re = /(\bfunction((?!function).)*\((.*?)\)\s*{)/i
str = '/** * recursive function to do whatever */ function demo (el, hop) { /*whatever*/ }
function to do whatever */ function demo (el, hop) {'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end