$re = '/(\bfunction((?!function).)*\((.*?)\)\s*{)/i';
$str = '/** * recursive function to do whatever */ function demo (el, hop) { /*whatever*/ }
function to do whatever */ function demo (el, hop) {';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);