# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([0-9]{4}-?[Xx0-9]{4})([^\n0-9].*)?$/\1/gm;t' <<< "1234-5678 ÿþT(zlsd?k+j''fh{l}x[a]j).,~!@#$%^&*()_+{}|:<>?`\"\;''/-
1234-5678
1234-567X
12345678
1234567X
1234567899
1234567899x"