#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^([0-9]{4}-?[Xx0-9]{4})([^\n0-9].*)?$"
Local $sString = "1234-5678 ÿþT(zlsd?k+j''fh{l}x[a]j).,~!@#$%^&*()_+{}|:<>?`"\;''/-" & @CRLF & _
"1234-5678 " & @CRLF & _
"1234-567X " & @CRLF & _
"12345678 " & @CRLF & _
"1234567X" & @CRLF & _
"" & @CRLF & _
"1234567899" & @CRLF & _
"1234567899x"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)