const regex = /^([0-9]{4}-?[Xx0-9]{4})([^\n0-9].*)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([0-9]{4}-?[Xx0-9]{4})([^\\n0-9].*)?$', 'gm')
const str = `1234-5678 ÿþT(zlsd?k+j''fh{l}x[a]j).,~!@#\$%^&*()_+{}|:<>?\`"\\;''/-
1234-5678
1234-567X
12345678
1234567X
1234567899
1234567899x`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);