// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([0-9]{4}-?[Xx0-9]{4})([^\n0-9].*)?$").unwrap();
let string = "1234-5678 ÿþT(zlsd?k+j''fh{l}x[a]j).,~!@#$%^&*()_+{}|:<>?`\"\\;''/-
1234-5678
1234-567X
12345678
1234567X
1234567899
1234567899x";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}