#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "<(p|span).*?>"
Local $sString = "<td style="blabla">" & @CRLF & _
" <p style="blabla">" & @CRLF & _
" tekst <span style=blabla">more text</span>" & @CRLF & _
" </p>" & @CRLF & _
" </td>"
Local $sSubst = "<\1>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)