$re = '/<(p|span).*?>/';
$str = '<td style="blabla">
<p style="blabla">
tekst <span style=blabla">more text</span>
</p>
</td>';
$subst = "<\1>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;