package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<(p|span).*?>`)
var str = `<td style="blabla">
<p style="blabla">
tekst <span style=blabla">more text</span>
</p>
</td>`
var substitution = "<\1>"
fmt.Println(re.ReplaceAllString(str, substitution))
}