import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(p|span).*?>";
final String string = "<td style=\"blabla\">\n"
+ " <p style=\"blabla\">\n"
+ " tekst <span style=blabla\">more text</span>\n"
+ " </p>\n"
+ " </td>";
final String subst = "<\\1>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}