#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(([A-Za-z]{2})((?=.*[a-z])(?=.*[A-Z])(?=.*\d)[0-9a-zA-Z]{10})\s)"
Local $sString = "Unter anderem sind auch JFgf545344fk zu finden. Aber nicht AZgf54gdfgdfgdg344kjh selle." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")