using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(([A-Za-z]{2})((?=.*[a-z])(?=.*[A-Z])(?=.*\d)[0-9a-zA-Z]{10})\s)";
string input = @"Unter anderem sind auch JFgf545344fk zu finden. Aber nicht AZgf54gdfgdfgdg344kjh selle.
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}