re = /(([A-Za-z]{2})((?=.*[a-z])(?=.*[A-Z])(?=.*\d)[0-9a-zA-Z]{10})\s)/i
str = 'Unter anderem sind auch JFgf545344fk zu finden. Aber nicht AZgf54gdfgdfgdg344kjh selle.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end