$re = '/(?<!\*)((?:\*\*)*)\*\*([^*\\\\\n]*(?:\\\\.[^*\\\\\n]*)*)\*\*((?:\*\*)*)(?!\*)/m';
$str = '**abc*def***
**abc*def**
**abc\\*def\\***
**abc def**
**hello \\* world**';
$subst = "\1*\2*\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;