re = /(?<!\*)((?:\*\*)*)\*\*([^*\\\n]*(?:\\.[^*\\\n]*)*)\*\*((?:\*\*)*)(?!\*)/m
str = '**abc*def***
**abc*def**
**abc\\*def\\***
**abc def**
**hello \\* world**'
subst = '\\1*\\2*\\3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result