#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[a-zA-Z áéíóúÁÉÍÓÚñÑ@&._$-]+"
Local $sString = "jhongranados@gmail.com" & @CRLF & _
"hola@gmail.com" & @CRLF & _
"buenas.com" & @CRLF & _
"@julio.com" & @CRLF & _
"123hhs@" & @CRLF & _
"1jh.com" & @CRLF & _
"1jh@s.com" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")