using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[a-zA-Z áéíóúÁÉÍÓÚñÑ@&._$-]+";
string input = @"jhongranados@gmail.com
hola@gmail.com
buenas.com
@julio.com
123hhs@
1jh.com
1jh@s.com
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}