re = /[a-zA-Z áéíóúÁÉÍÓÚñÑ@&._$-]+/m
str = 'jhongranados@gmail.com
hola@gmail.com
buenas.com
@julio.com
123hhs@
1jh.com
1jh@s.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end