using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(http(s)?)://(www.)([a-zA-Z]){3,}.([a-zA-Z]){2,3}$";
string input = @"https://www.google.fr";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}