$re = '/^(http(s)?)://(www.)([a-zA-Z]){3,}.([a-zA-Z]){2,3}$/';
$str = 'https://www.google.fr';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);