package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(http(s)?)://(www.)([a-zA-Z]){3,}.([a-zA-Z]){2,3}$`)
var str = `https://www.google.fr`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}