const regex = new RegExp('^(http(s)?)://(www.)([a-zA-Z]){3,}.([a-zA-Z]){2,3}$', '')
const str = `https://www.google.fr`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}