import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[^%]|%%)+(%)(?!%|(?<flags>[-+#0])?(?<width>\\d+|\\*)?(?:\\.(?<precision>\\d+|\\*))?(?:(?<specifier>[diuoxXfFeEgGaAcspn]))|(?<length>[hljztL]|hh|ll)(?P=specifier))";
final String string = "test 10%% test test test = test in test 10%%% test = 2 test %d %test % test %, a testtesttest 25%%\n\n"
+ "Some different radices: %d %x %o %#x %#o\n"
+ "floats: %4.2f %+.0e %E ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}