import Foundation
let pattern = ##"(?:[^%]|%%)+(%)(?!%|(?<flags>[-+#0])?(?<width>\d+|\*)?(?:\.(?<precision>\d+|\*))?(?:(?<specifier>[diuoxXfFeEgGaAcspn]))|(?<length>[hljztL]|hh|ll)(?P=specifier))"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
test 10%% test test test = test in test 10%%% test = 2 test %d %test % test %, a testtesttest 25%%
Some different radices: %d %x %o %#x %#o
floats: %4.2f %+.0e %E
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)