const regex = /(?:[^%]|%%)+(%)(?!%|(?<flags>[-+#0])?(?<width>\d+|\*)?(?:\.(?<precision>\d+|\*))?(?:(?<specifier>[diuoxXfFeEgGaAcspn]))|(?<length>[hljztL]|hh|ll)(?P=specifier))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:[^%]|%%)+(%)(?!%|(?<flags>[-+#0])?(?<width>\\d+|\\*)?(?:\\.(?<precision>\\d+|\\*))?(?:(?<specifier>[diuoxXfFeEgGaAcspn]))|(?<length>[hljztL]|hh|ll)(?P=specifier))', 'g')
const str = `test 10%% test test test = test in test 10%%% test = 2 test %d %test % test %, a testtesttest 25%%
Some different radices: %d %x %o %#x %#o
floats: %4.2f %+.0e %E `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}