$re = '/(?:[^%]|%%)+(%)(?!%|(?<flags>[-+#0])?(?<width>\d+|\*)?(?:\.(?<precision>\d+|\*))?(?:(?<specifier>[diuoxXfFeEgGaAcspn]))|(?<length>[hljztL]|hh|ll)(?P=specifier))/';
$str = 'test 10%% test test test = test in test 10%%% test = 2 test %d %test % test %, a testtesttest 25%%
Some different radices: %d %x %o %#x %#o
floats: %4.2f %+.0e %E ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);