using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[-\w ]+(,[-\w ]+)+$";
string input = @"
1000,two thousand,3000
1000 , 2000 , 3000
First Option,2Nd Option, THIRD Option
Single Value
1000 ,, 2000 , 3000
1000 , 2000 , 3000,
1000 , 2000 , 3000,,
,,1000 , 2000 , 3000";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}