$re = '/^[-\w ]+(,[-\w ]+)+$/m';
$str = '
1000,two thousand,3000
1000 , 2000 , 3000
First Option,2Nd Option, THIRD Option
Single Value
1000 ,, 2000 , 3000
1000 , 2000 , 3000,
1000 , 2000 , 3000,,
,,1000 , 2000 , 3000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);